Placa base ASUS M2N-SLI DELUXE, disco IDE y waiting for root file system [Solucionado]

Buenas,

Tengo una placa base ASUS M2N-SLI DELUXE, junto con disco duro IDE y una grabadora conectados a la ranura IDE de la placa.
El disco está como secundario, siendo por tanto hdb.

El problema es que al arrancar unas veces el arranque lo reconoce como tal, pero otras lo reconoce como hdf y por consiguiente se para en un "waiting for root file system".

He googleado como es preceptivo, en este foro encontré este hilo:

http://esdebian.org/foro/18007/kernel-26215-begin-waiting-for-root-f...

También he probado a compilar un núcleo 2.6.25 desde las fuentes, pero sin éxito pues no sé qué módulo o módulos debo añadir o quitar.

Lo más penoso es que parece que con cada actualización del núcleo arranca cada vez más con hdf que con hdb, con lo que tengo que resetear cada vez más veces hasta encontrar el hdb.

Uso Lenny, y esto ya me ha pasado siempre, incluso con el núcleo 2.6.18.

Salud2

EDITO: no he puesto correctamente el enlace y no se ve, por lo dejo como texto.

Creo que los temas que te vendrían bien son estos:

http://esdebian.org/foro/21035/al-reiniciar-cambia-hda-hde-soluciona...

http://esdebian.org/foro/20387/problemas-arrancando-sistema-operativ...

Hace tiempo tuve un problema parecido y lo he solucionado como indican.

Gracias Emo, sí que me van a venir bien. En un primer vistazo se ven buenas soluciones.

Cuando lo solucione editaré este comentario.

Desde luego tengo que esmerarme algo más con las palabras de búsqueda :)

Un saludo

vespertilum escribió:

Gracias Emo

No era necesario faltar al respecto a nadie... XD

Sin intención de faltar, ya se sabe, la tipografía la carga el diablo silbo meparto

Ya está solucionado, gracias de nuevo Erno bigsmile

maxmalkav escribió:
vespertilum escribió:

Gracias Emo

No era necesario faltar al respecto a nadie... XD

emo

Sniff, sniff